Tuesday, March 15, 2011

Gathering Solaris system information

As a fusion admin/architect most of the times one needs to gather basic information about the server on which the fusion application runs. Below are some solaris commands that can be used by an admin for gathering system information on a Solaris machine.The below commands work well on Solaris 7 and above. The same commands can be used on solaris zones(virtualized servers).


Processor Info


The psrinfo utility displays processor information. When run in verbose mode, it lists the speed of each processor and when the processor was last placed on-line (generally the time the system was started unless it was manually taken off-line).


/usr/sbin/psrinfo -v
Status of processor 1 as of: 12/12/02 09:25:50
  Processor has been on-line since 11/17/02 21:10:09.
  The sparcv9 processor operates at 400 MHz,
        and has a sparcv9 floating point processor.
Status of processor 3 as of: 12/12/02 09:25:50
  Processor has been on-line since 11/17/02 21:10:11.
  The sparcv9 processor operates at 400 MHz,
        and has a sparcv9 floating point processor.


The psradm utility can enable or disable a specific processor.


To disable a processor:
/usr/sbin/psradm -f processor_id


To enable a processor:
/usr/sbin/psradm -n processor_id


The psrinfo utility will display the processor_id when run in either standard or verbose mode.


RAM Info


The prtconf utility will display the system configuration, including the amount of physical memory.


To display the amount of RAM:


/usr/sbin/prtconf | grep Memory
Memory size: 3072 Megabytes


Disk space Info


Although there are several ways you could gather this information, the following command lists the amount of kilobytes in use versus total kilobytes available in local file systems stored on physical disks. The command does not include disk space usage from the /proc virtual file system, the floppy disk, or swap space.


df -lk | egrep -v "Filesystem|/proc|/dev/fd|swap" | awk '{ total_kbytes += $2 } { used_kbytes += $3 } END { printf "%d of %d kilobytes in use.\n", used_kbytes, total_kbytes }'
19221758 of 135949755 kilobytes in use.


You may want to convert the output to megabytes or gigabytes and display the statistics as a percentage of utilization.


The above command will list file system usage. If you are interested in listing physical disks (some of which may not be allocated to a file system), use the format command as the root user, or the iostat -En command as a non-privileged user.


Processor and kernel bits Info
If you are running Solaris 2.6 or earlier, you are running a 32-bit kernel.


Determine bits of processor:
isainfo -bv


Determine bits of Solaris kernel:
isainfo -kv


Hope the above info helps. I would be blogging more on unix level commands/scripts which would aid you manage and troubleshoot fusion instances.Looking forward to your valuable suggestions...

No comments:

Post a Comment